The Athos app requires iOS 8.0+. We are compatible with the iPhone and iPad that supports Bluetooth Low Energy protocol. The app is also optimized for iPhone 5, iPhone 6, and iPhone 6 Plus. Get the App for free here.

Did this answer your question?